To access Forum, you must use the Google Chrome web browser. Forum is not compatible with any other browser.

You can find the latest version of Google Chrome on this download page.

If you already have Google Chrome installed, update it by clicking the More button in the upper right corner of the browser and then clicking Update Google Chrome. If there is no Update Google Chrome button then you are using the latest version.

Did this answer your question?